gcc 4.7.2 linux build broken

Description

Problem with 4.7.2 and inheriting constructors:

Hello,

Upgrading from v1.1.0 to v1.2.0 I'm getting a build error in my setup.

So this is centos 6.5 w/ devtoolset-1.1 installed

Problem for me is:
include/fix8/sessionwrapper.hpp:

Is my compiler too old? I couldn't find a list of supported compilers on the website or wiki.

I can either remove the ifdef true clause or define the it (which seems wrong), but would prefer if this would just work out of the box.

What do you think?

Click here to Reply

David Dight
09:59 (1 minute ago)

Looks like gcc 4.7.2 doesn't support inheriting constructors. Try 4.8
We might roll this back since we need to support at least 4.7.2 (which has most of the C++11 features we use).
/dakka

Environment

None

Assignee

David Dight

Reporter

michael drago

Labels

Branch

master

Products

None

Components

Fix versions

Affects versions

Priority

Major
Configure